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The manual modified on September, 10, 2001
General Information

“SlovoEd” is a multi-language dictionary for devices with Palm OS 3.0, 3.1, 3.3, 3.5 or 4.0. Advantages of the program are convenient interface with colour support, the possibility to add new entries and change existing entries, quick translation, a large number of word entries and low memory consumption, the possibility to install several language pairs
. SlovoEd supports the right sorting order for each national language according to its alphabet. For example some languages (Czech, Slovak, Hungarian and so on) have special letters and combinations of letters like [image: image2.png]a;8,¢, ¢ hych I, I'



, which are considered as one letter.  In spite of it dictionary entries are listed in the right order.
The dictionary also includes a resident module that allows you to translate words without exiting an active application. The program runs fast and effectively despite the high data compression ratio.
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For each language pair there may be several configurations of dictonaries for “SlovoEd” software engine
: compact, extended, basic and so on. If you need to translate words not very often or if you don’t have enough memory on your Palm device, we recommend you to install compact configuration. But if you often work with non-national texts or often translate from your native language to another then we recommend you to install extended configuration.

For example, you can see both configurations characteristics for Russian-English pair:

	Configuration
	Space Reguired
	Russian-English
	English-Russian

	Compact
	690 Kb
	> 34,000 word entries
	> 29,000 word entries

	Extended
	867 Kb
	> 61,000 word entries
	> 55,000 word entries


Such a high data compression ratio for dictionaries with a high access rate is available due to special technology developed by Paragon Software (SHDD) (http://www.penreader.com). 
Demo-version limitations:

· The more you use the unregistered dictionary, the more you see a message about registration procedure. To register your copy of the dictionary you should enter serial number in the following dialog:
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The information about buying SlovoEd and getting the serial number is available at our web site www.penreader.com/PalmOS/SlovoEd.html using link BUY.

Installation

If you have old version of SlovoEd installed, you should remove it first. You can read about uninstallation procedure in appropriate documentation to installed version.

The following files are required for “SlovoEd” dictionary installation:

SlovoEd.prc
- ”SlovoEd” program with English interface

SlovoEdXXXX.prc – ”SlovoEd” program with interface in national language (XXXX – is abbreviated name of national language)

Choose only one interface: English or national.

In addition, you have to install dictionary files (two files for bi-directional dictionary and one file for uni-directional dictionary). For example, for bi-directional English–French dictionary you have to install French_English.prc and English_French.prc, for uni-directional German-Spanish dictionary only German_Spanish.prc.

Using “SlovoEd”

Attention! If you want to use national language dictionaries, and this national language has symbols, that are not supported by standart Palm OS (for example, Russian, Greek or Turkish symbols), then you have to install National language support system (that allows you to use national symbols on your Palm). Only in that case you can type words on national language and “SlovoEd” can display translations with specific national symbols correctly. If you don’t install natonal localization system, you will see unreadable symbols (gibberish)
.

If localization system is installed on your Palm OS device, you should set national languge as a system one
.  After starting the program your organizer’s screen will appear as follows:
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There is an edit field for entering words to be translated at the bottom of the screen. You can enter words in this field in different ways:

· Using Graffiti. 
· Using the on-screen keyboard.
· By performing a “Paste” operation – (if you have previously copied a word to the Clipboard). You can paste with the help of the menu, Graffiti or by clicking on the appropriate button at the top of the screen.
· By turning on the Paste on start option in Options menu. With this option the Clipboard contents will be pasted into the edit field every time the program starts.
If a word is entered in the field and it exists in the dictionary, its translation will be displayed below the edit field.

You can look through the dictionary by clicking the arrows on the screen or by pressing hardware buttons the Up/Down on your Palm organizer’s case.

The elements of the program interface are shown at the picture below:
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1. Edit field.

2. Words, those are available in the dictionary.

3. Arrows for scrolling the words list. You can also scroll the list with the help of the hardware buttons Up/Down on your device.

4. Translation of the word entered in the edit field (lexical entry). The syntactic meaning of the word is enclosed in the triangular brackets. The semicolons separate different meanings of the word. 

5. Scrollbar. You can scroll the long translation list when the content doesn’t fit the screen.

6. Graffiti indicator
. Allows you to see the current language operation mode of Graffiti, and allows you to switch between national and default languages. If you use localization system PiLoc 2.0 and higher the indicator allows you to switch between dictionaries in the pair.
7. “Dictionary” button. Switches between the dictionaries in the active pair. You can also choose the appropriate dictionary with the help of the program menu. If you customize a hardware button to select “SlovoEd” and you ran the program by pressing this button, pressing the button a second time will change the active dictionary to the opposite one. While you are changing the active dictionary, a word entered in the edit field remains there only if it consists of letters from alphabet of  “new” active dictionary. For example, you are in the French-English dictionary and you type the word «À côté de». If you change the active dictionary to English-French the word is removed automatically from the edit field. If you are in English-French dictionary (English alphabet is active) and you type the word «betterave» and then change dictionary to French-English, the word remains in the edit field and the program start translate searching operation.

Thus the active dictionary is changed every time you start typing a word with a letter that doesn’t belong to current active alphabet. For example, if English-French dictionary is active and you start typing «À côté de» the program automatically changes the active dictionary to French-English.

8. “Clear” button. Clears the edit field.

9. “Select” button. Allows you to select all the contents of the edit field.

10. “Paste” button. Inserts the Clipboard contents in the edit field.

11. “Copy” button. Allows you to copy selected word into the Clipboard.

“SlovoEd” has a menu that includes three items.
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The Edit menu allows to perform Copy, Paste, Select and Clear operations with text in the edit field. In addition you may call keyboard or Graffiti help.

The Dictionary > Change dictionary menu allows you to change the active dictionary or delete available dictionaries.
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You can choose an active dictionary and delete any dictionary from the list.

Attention! If you delete a dictionary from the list, in case it is bi-directional, the pair dictionary will also be deleted. For example, if you want to delete English-French part of bi-directional dictionary, it will be deleted along with French-English dictionary.

Menu Dictionary->Add new entry allows you to add new word entries in any dictionary.
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You can change any existing entry in the dictionary with menu Dictionary->Edit selected entry:
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Use menu Dictionary->Delete selected entry for deleting dictionary entries.

You can disable your changes of the dictionary at any time you wish (in Options menu):
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Menu item About… allows you to know what dictionaries are active now and how many entries are available in every dictionary.

[image: image16.png]Dictionary Slovokd 3.0b

Company Paragon Software
et penveader com
Support. msupportapenveoder.com|

Dictionrisscontan
RussanEngien s
Engih - Russion b

Ditonary bases by
Aesenal





You can tune “SlovoEd” functionality as you wish in the Options menu. 
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· Paste on start. If you choose this option, the Clipboard content is inserted in the edit field every time you start “SlovoEd”.

· Paste selected text when changing dictionaries. When you change the active dictionary, a text selected in the translation field will be automatically pasted into the edit field.

· Do copy with Exit. When you close the dictionary, translation fields’ contents are copied automatically into the Clipboard. These options is very useful if you are typing a document or E-mail message and want to look up some words occasionally. If this option is active, you should find the translation, select it, then exit the program, return to the document or E-mail message and perform paste operation.

Attention! The content of the translation field may includes many words.
· Small letters in translation. If the translation contains many words, you can make the fonts in the translation field a bit smaller to improve translation readability.

· Save last entered word. The program saves in the Clipboard the word that was entered in the edit field before exit. If you run program again, the dictionary will start searching for this word. The word will be pasted into the edit field from the Clipboard. If Paste on start is also active, this option works only if you didn’t copy any text into the Clipboard before running the dictionary.

· Disable all users dictionary changes – this function disables all changes you made, such as adding, editing, deleting dictionary entries in original dictionaries.

· Resident options. You can select from a popup menu, weather the resident module of “SlovoEd”on and how it is activated.
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Using the resident module

If option No resident activated in Options menu is NOT selected then the resident part of the program will run. It allows you to translate words without exiting an application that is currently active. Just select the word you would like to translate and start the resident module by method you have set in the Options dialog. Then you will see a window at the bottom of the screen. If the dictionary doesn’t contain this word, you’ll see a list of neighbouring words. 

If the word is included in the dictionary you will see its translation.
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While working with the resident module you use the options that were previosly selected in Options dialog of the main program. If these options don’t suit you or you don’t like the functionality of the resident module, you can run the main program with the help of menu or the menu shortcut [image: image20.png]


E. You can copy the translation into the Clipboard either manually or automatically (if you checked the option Do Copy with Exit in the Options menu).

You can close the resident module window by pressing on the close button in the right corner of the resident window or by clicking anywhere but the resident window. You can also close the resident window by selecting item Exit in the File menu or by the shortcut [image: image21.png]


I.

You can switch between dictionaries in the active pair by selecting the Change dictionary item from the menu or by the shortcut [image: image22.png]


T.

When the resident displays the translation list, you can return to search mode by selecting the Go to Search item in the File menu, by tapping [image: image23.bmp] button, or using Backspace shortcut in Graffiti field.
If the translation list is being displayed, you can go to the translation of the previous or next entries by pressing the Up/Down hadware buttons on your device.

Attention! The program has a repeating reboot protection. In case the device reboot occurs more than once a minute, the resident part of “SlovoEd” doesn’t run.

Support and updates service
If you have any questions concerning SlovoEd and PiLoc programs contact technical support service of Paragon Software (SHDD):

Tel: (095) 408-61-79, 408-76-77 

(Telephone line of technical support works till 11.30 to 19.00)(
Web: http://www.penreader.com 

msupport@penreader.com
Paragon Software (SHDD) has organized web-conference for PDA users. Here you can ask any question about PDA (software and hardware), Paragon Software programs and discuss any problems concerning mobile devices with other PDA users. You can write there in English and in national language.

Welcome to our web-conference: http://mboard.penreader.com
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If you have a credit card you can buy SlovoEd and PiLoc as well as our programs for other mobile platforms (Windows CE/Pocket PC, EPOC/Psion) in Digital River secure network: http://buy.penreader.com/    or

http://www.digitalriver.com/dr/v2/ec_Main.Entry?SP=10007&SID=18212&CID=0
Dear users!

We would be glad to get your offers and comments that would help us to increase our programs quality.

Thanks a lot in advance for your comments and ideas!


Multi-language dictionary  


“SlovoEd”
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� Information about all dictionaries which we develop is available at � HYPERLINK "http://www.penreader.com/PalmOS/SlovoEd.html" ��www.penreader.com/PalmOS/SlovoEd.html� using link DOWNLOAD.


� What configurations of the dictionary are available for each language pair you can read at  our web site � HYPERLINK "http://www.penreader.com/PalmOS/SlovoEd.html" ��www.penreader.com/PalmOS/SlovoEd.html� using an appropriate link in section More languages.


� You don’t need to install national localization system if you use English, German, Hungarian and French languages.


� We recommend you to use our localization system PiLoc. You can find more detail information about PiLoc at our web-site: � HYPERLINK "http://www.penreader.com" �� http://www.penreader.com/PalmOS/PiLoc.html � 


Demo versions of PiLoc are available at � HYPERLINK http://www.penreader.com/trynow.htm �� http://www.penreader.com/PalmOS/PiLoc.html �using link DOWNLOAD.


� If you install national localization system.





( When calling from outside Russia, please consider time shifts: Moscow is 11 hours ahead of San-Jose, 8 hours ahead of New York, 3 hours ahead of London, 2 hours ahead of Munich and Paris, 6 hours behind Tokyo. Moscow office operation hours are from 11.30 till 19.00 by Moscow local time.
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